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(a) Osteoarthritic Glenoid

Posterior to Anterior (scaled)

Inferior
to

Superior

(b) Predicted Intact Glenoid

Figure 7.8. The original geometry of an osteoarthritic glenoid compared with its pre-
dicted healthy geometry. These glenoids were created by using the original

The new PC scores, created by the process in 7.2, were transformed using the

methodology from Chapter 6 into the scaled CSP/TSP frame of reference. Meshes

were generated by using RBFs to represent the new landmark locations using both

the original mesh of the shoulder, as well as the set baseline mesh.

These meshes were returned into the CSP frame of the original glenoid by

doing a procrustes transformation using POI1 and the anterior vault landmarks

as a reference. A sphere-fit was conducted to measure the changes. The glenoids

were evaluated at five levels of restoration: 0%, 25%, 50%, 75%, and 100%. The

changes resulted in direct changes to the sphere fit version and inclination, shown

in Tables 7.2 and 7.3

The landmark placement showed the overall shape of the glenoid, but was
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Anterior to Posterior (mm)

Inferior
to

Superior

(a) Osteoarthritic Glenoid

Inferior
to

Superior

Posterior to Anterior (mm)

(b) Predicted Intact Glenoid

Figure 7.9. The RBF produced geometry of an osteoarthritic glenoid compared with
its predicted healthy geometry.

not appropriate for removing bone spurs on the glenoid. For these preliminary

results the values of PC 1 and PC 2 were linearly brought to the mean values for

a healthy glenoid. This is an estimation of what the glenoid may have looked like.

Table 7.2. Difference in sphere fit from osteoarthritic to glenoid when using the original
mesh for the RBF transformation. A ratio of the original sphere fit is displayed

Patient Sphere Adjustable Fixed
ID radius ratio Ver. (◦) Inc. (◦) Ver. (◦) Inc. (◦)
6 0.98 0.3 0.9 0.2 1.0
7 1.02 5.6 -0.6 5.6 -0.6
11 0.93 19.7 -6.5 19.7 -6.0
30 1.01 4.1 -1.2 4.1 -1.3
37 1.19 13.8 -6.6 14.3 -6.5
39 0.97 8.4 -2.1 8.3 -2.0
40 1.02 12.8 -2.4 12.7 -2.6
41 1.20 11.2 -4.4 11.4 -4.8
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The glenoid decreases in size, and has less retroversion.

In order to test whether or not the predicted healthy angles were feasible for

implant placement, the depth available behind the glenoid sphere center at the

predicted healthy angle was measured. Table 7.4 displays the length behind the

glenoid vault, along with the percentage comparison. Approaching at the predicted

healthy angle did not hinder vault length, and in the majority of the shoulders

approaching at the predicted healthy angle resulted in greater vault depth.

An increase of space by reorienting the angle of approach indicates the validity

Table 7.3. Difference in sphere fit angle results from osteoarthritic to glenoid when
using RBFs with the baseline mesh. A ratio of the new sphere size to original sphere
size is displayed.

Patient Sphere Adjustable Fixed
ID radius ratio Ver. (◦) Inc. (◦) Ver. (◦) Inc. (◦)
6 .99 0.2 0.9 0.2 1.0
7 1.02 5.6 -0.7 5.5 -0.7
11 1.05 19.4 -7.1 19.5 -7.1
30 1.03 4.2 -1.2 4.3 -1.3
37 1.26 13.3 -6.6 14.2 -6.7
39 .98 8.5 -2.1 8.4 -2.0
40 .97 15.7 1.06 15.7 -3.3
41 1.25 11.5 -5.37 11.9 -5.1

Table 7.4. Vault depth available for implants behind the osteoarthritic sphere center
when approached at the predicted healthy angle

Patient ID Vault Depth (mm) Percent of Original Depth (%) Percent of CSP Depth

6 21.9 100 87
7 21.7 100 86
11 22.9 180 112
30 21.7 99 172
37 18.4 145 97
39 12.9 161 136
40 22.5 141 119
41 23.8 115 116
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of these predicted geometries. Placing an implant at the sphere fit location in a

healthy shoulder resulted in greater space for the implant pegs than approaching

at the CSPlane. However, this pattern was not valid for osteoarthritic shoulders,

as was seen in Chapter 3. The improvement on vault depth by approaching at

the predicted healthy angle implies that this methodology of predicting intact

geometry is valid.

7.2.1 Assumptions and Limitations

One assumption was that the location of the sphere fit center stayed constant with

respect to the topology of the changing glenoid. Since this may have resulted

in a different sphere center than one selected manually, the differences in version

and inclination angles were noted as PC 1 and 2 were altered, and were used for

calculating vault depth, rather than the sphere fit center location.

To determine the orientation of the glenoid vault within the CSP-TSP plane,

a procrustes transformation was taken to transform the generated landmark lo-

cations on the anterior side of the vault to match that of a baseline patient. For

the prediction of the healthy vault angles, the original locations of the anterior

vault landmarks for each osteoarthritic shoulder were used as the basis for the pro-

crustes transformation. This was due to the assumption that osteoarthritis effects

the posterior side of the glenoid more than the anterior, and the anterior landmark

locations would not change with osteoarthritis.

The landmark location was not dense enough to show the growth of bone spurs

within the geometry of the data. In order to compensate for this problem, radial

basis functions were used with both an intact geometry and an osteoarthrtic geom-

etry as the baseline. The sphere fitting results for both versions were comparable.
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7.3 Contributions

The purpose of this research was to create a model that can generate intact and

osteoarthritic shoulders. A set of landmark locations were selected to represent

the topology of the glenoid. These landmark locations were transformed into a

PC frame of reference, to find the variability that correlated with osteoarthritis.

By manipulating the PC scores, a suite of shoulder geometries were created within

the observed variability from existing shoulders. The scores of the first two PCs

were altered to predict the previous healthy geometry for the existing osteoarthritic

glenoid. Inserting an implant at the predicted intact angle resulted in greater space

for peg length than at the sphere fit angle for an osteoarthritic face, indicating that

there is validity to the intact geometry prediction.

7.4 Post Dissertation Work

Using the modeling results, a method of accurately assessing implant placement

during surgery will be created. The implant will also be redesigned to return the

arthritic shoulder to healthy glenoid orientation by taking into account the original

glenoid geometry. The impact of this research on design-decision making processes

in general will be explored for further research opportunities. If this research is

successful I will look to work with industry to implement the methodology.

The model representing the variability within glenoids may be useful for sur-

geons. However, this model will have to be further validated before human testing

would be feasible. These tests would need to prove the hypothesis that (1) the pre-

dicted healthy version of the glenoids are accurate and (2) restoring the glenoid to

its original state is the best for patient outcomes. Adding further scapula with high

quality CT-scans may also improve upon the predictive accuracy of this method.
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7.4.1 Previous Surgery Study

A short term non-invasive way to test these results would be to find long-term

TSA studies in which CT scans were taken before and after surgery. A predicted

healthy glenoid would be created for the shape of the osteoarthritic glenoid prior

to surgery. The angle that this model would predict would be compared to the

angle that the implant was placed.

The differences in patient outcomes between the surgical results for glenoids

that were restored to their predicted healthy value, as opposed to glenoids that

were not, would indicate the validity of the prediction that restoring shoulders to

their predicted healthy outcomes is a useful endeavor.

7.4.2 Longitudinal OA Study

One goal of this project was to predict the shape changes that occur with GHOA.

A long term study that would show the accuracy of these predictions would be to

find patients who have GHOA prior to their need for surgery. The changes in their

shoulder shape could be quantified over time through periodic CT scans. It may

be possible that some glenoid shapes are more prone to GHOA than others, and

this study could assist in identifying which shapes, if any, are at risk.

7.4.3 Implant Design Study

With enough evidence that this model is useful, these data can be used to design

implants for glenoids in the future. Predicting the original healthy angle could

improve upon step prosthetic design. It may be possible to use these results in

collaboration with current step prosthetic designs.
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7.5 Conclusion

This project was conducted to identify the variability between healthy and os-

teoarthritic shoulders for the purpose of improving TSA outcomes. For this re-

search CT scans of healthy and osteoarthritic glenoids were processed and studied

in order to quantify the effects of glenohumeral osteoarthritis on the shape and

orientation of the glenoid. The results of these studies were used to model both

intact and osteoarthritic glenoids.

These osteoarthritic models can be useful in the endeavor to design appropriate

implant families. By having a prediction of the healthy geometry, the angle of

restoration and the size of the glenoid can be used to select implant step levels.

Implant sizing would need to reflect the variability in sizes of the glenoid face, and

the different restoration angles needed to support the humeral head. This method

of landmark setting, shape morphing and population generation may be useful for

implant design for any bone, as well as design for external human figures.



Appendix A
Glossary

As this is an engineering view of a medical problem, a glossary of terms is included

to clarify any cross disciplinary confusion.

A.1 Medical Terms

landmarks is shown in Figure 2.1 A visualization of the scapula and the surrounding

bones are shown in Figure 2.2.

A.2 Acronyms

BMI Body-Mass Index

CSP Coronal Scapular Plane

CT Computed Tomography

GHOA Glenohumeral Osteoarthritis

HSA Hemi-shoulder Arthroplasty
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TSP Transcoronal Scapular Plane

TSA Total Shoulder Arthroplasty

A.2.1 Directional Terms

Anterior Approaching the front surface of the body

Posterior Approaching the back surface of the body

Inferior Approaching the soles of the feet

Superior Approaching the top of the head

Medial Approaching the middle of the torso from the left/right

Lateral Approaching the left or right from the middle of the body

A.2.2 Scapula Landmarks

Glenoid The cavity on the scapula which cups the humerus in the shoulder joint

Glenoid Face The concave section of the glenoid

Vault The thin neck behind the glenoid

Lateral Border The border of the spine

Medial Boarder The furthest edge

Coracoid Process The lateral-most protrusion superior to the glenoid

Spine The protrusion from the blade of the scapula
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A.2.3 Other Terms

Congenital Existing at or before birth

Humerus The upper arm bone that connects with the glenoid at the shoulder

joint

Hypoplasia Underdevelopment of a tissue or organ

Subluxation A partial dislocation of a joint

Supine Lying on the back, face upwards

Retroversion The tipping backward of an organ or body part

Rotator Cuff The set of muscles and tendons that secure the arm to the shoulder

joint

A.3 Engineering Terms

A.4 Acronyms

DfHV Design for Human Variability

PC Principal Component

PCA Principal Component Analysis

RBF Radial Basis Function



Appendix B
Total Shoulder Arthroplasty

The following images were taken during a Total Should Arthroplasty from August

of 2014. The patient was a man who was having an implant placed in his right

shoulder. The surgery was conducted by Dr. April Armstrong at the Pennsylvania

State University Hershey Medical Hospital. This surgery was performed with a

Zimmer implant.

B.1 Preoperative

Prior to the surgery, x-rays of the patient were taken to show the status of the joint

(Figure B.1). During surgery, a representative from Zimmer is present for consul-

tation in implant selection (Figure B.2). Several sizes of implants are available,

and the size of the implant is selected during surgery.

The patient is prepped such that the For this surgery the patients arm is held

by one of the surgeons, rather than being strapped down. This allows the arm to

be maneuvered to dislocate the humerus.
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Figure B.1. The X-Ray on display of the shoulder prior to surgery.

B.2 Humeral Implant

The incision is made to span the length from the lateral edge of the coracoid

process, (located on the scapula) to the deltoid muscle (Figure B.4). The deltoid

muscle and the tendons of the biceps must be retracted to gain access to the

glenohumeral joint (Figure B.5). An incision must then be made into the muscle,

and the humerus is dislocated to have full access to the humeral head (Figure B.6).

The head of the humerus is cut off using an oscillating saw (Figure B.7). The

removed section of the humeral head (Figure B.8) is placed aside.

The humeral implant contains a stem that is placed inside the cavity of the

humerus, and a head that attaches to the stem. In order to place the stem, the



99

Figure B.2. The surgical tools and implants of various sizes are on hand, along with a
consult from Zimmer.

medullary cavity of the humerus is increased using remers (Figure B.9). The size

of the humeral head is determined by the surgeon, and is attached to the stem.

When the humeral implant is fully set (Figure B.10), the glenoid implant can be

inserted. In HSA, the surgery would be finished with only the humeral component.

B.3 Glenoid Implant

Very little of the scapula can be seen during surgery; only the glenoid face is

visible (Figure B.11). Three holes are drilled into the center of the glenoid face

(Figure B.12). These holes are cleaned (Figure B.13) and cement is placed in
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Figure B.3. The patient right before incision, with the incision site marked on the
shoulder.

the holes. The glenoid implant (Figure B.14) is made from polyethylene and has

three pegs that fit within the holes. The size is chosen to fit the glenoid, as well

as to match the corresponding humeral implant. The implant is held in place

(Figure B.15) as the glenoid hardens. A final view of both implants in contact is

shown in Figure B.16.



101

Figure B.4. The first incision is made.
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Figure B.5. The deltoid muscle and the tendons of the biceps must be retracted to
gain access to the glenohumeral joint.
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Figure B.6. Dislocation of the humerus to gain access to the head.
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Figure B.7. Cutting off the humeral head.



105

Figure B.8. The removed humerus is set aside.
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Figure B.9. Increasing the medullary cavity of the humerus.
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Figure B.10. The humeral stem implant is hammered into place, and the size of the
implant head is chosen.
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Figure B.11. The exposed glenoid.
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Figure B.12. Three holes are drilled into the glenoid face.
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Figure B.13. The cleaned three holes
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Figure B.14. The three pegged glenoid implant.
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Figure B.15. The glenoid implant is held in place as the cement hardens.
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Figure B.16. The final view of the humeral and glenoid implants before the joint is
closed.



Appendix C
Processing CT Scans

This appendix covers the process of isolating the CT scans in Osirix, Netfabb, and

Meshlab.
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C.1 Mesh Generation in Osirix

Importing FilesImporting Files
Osirix is an open source software used to view and process DICOM files. It was used in this research to
isolate the scapula from the other bones and soft tissue from the CT scans of healthy and osteoarthritic
patients.

Open up Osirix. In order to import the files, press the import button, or use File->Import->Import Files.
In this main window it is possible to see the patient ID, the study description, the date the scans were
taken, and to add notes about the patient. Double click on the patient name to view the file in the 2D
viewer.

Isolating the Scapula in Osirix
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Finding the ScapulaFinding the Scapula
When looking through 2D viewer, it is possible to scroll through the CT slices. This is also the view
used to grow a region of interest. Scroll until you are sure you are looking at the scapula.

Isolating the Scapula in Osirix
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Growing a Region of InterestGrowing a Region of Interest
A region of interest (ROI) can be calculated based on the pixel values of each scan. This can be used to
identify tumors, organs, or in this case, individual bones. To grow a 3D ROI, go to the tool bar and
select ROI->Grow Region. This will open up the Segmentation Parameters window.

For this process, select "Threshold" from the Algorithm drop down list. Set the lower pixel value to 350,
and upper to 3000. Make sure to create a Brush ROI, and set the name to "scapula." Click compute to
generate the ROI. To fill in the scapula, use ROI->Brush Tools-> Closing. This increases the ROI to the
marrow cavities of the bone.

Isolating the Scapula in Osirix
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Complications with ROIs: Extra BonesComplications with ROIs: Extra Bones
Be sure to scroll through the CT scans to make sure the ROI is accurate. Occationally, the ROI may have
some errors. In this case the humerus was included in the ROI with the scapula. If this occurs, delete the
ROI using ROI->Delete All ROIs in this Series.

Isolating the Scapula in Osirix
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Removing the HumerusRemoving the Humerus
Using a higher pixel value can result in much thinner walls, and can exclude parts of the bone.
However, since we want to get rid of the humerus, we will set the lower bound of the pixel value to
500. This ensures that the ROI will only cover the humerus.

Isolating the Scapula in Osirix
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Changing Pixel ValuesChanging Pixel Values
ROIs are useful in that the pixel values can be temporarily changed. If the 2D view window is shut, the
pixels will return to normal when the window is reopened, and the ROIs will remain unchanged. In
order to ignore the humerus, the pixel values of the humerus ROI will be set to black. Go to the tool bar,
and use ROI->Set Pixel Values to....

In the window select ROIs with the same name as the selected ROI, inside ROIs, and to this new value.
The new value should be -3024 in order to completely ignore the humerus.

Isolating the Scapula in Osirix
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Complications: ROI ImperfectionsComplications: ROI Imperfections
Using the ROI generater/closing tool still does not result in a perfect scapula. In the following image,
the ROI does not include the complete scapula and cavity.

Isolating the Scapula in Osirix
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Complications: Extra pixelsComplications: Extra pixels
Another possible complication is the ROI covering segments outside of the bone.

Isolating the Scapula in Osirix
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Using the Brush ToolUsing the Brush Tool
In order to fix holes or get rid of extra pixels, the brush tool can be used to alter the ROI. Use the draw
mode to add to the ROI, and the erase mode to take away from it. The size represents the diameter of
the brush.

Isolating the Scapula in Osirix
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Brush Tool: ComplicationsBrush Tool: Complications
Be careful when using the draw/erase brush tool. It is very easy to accedentally select the ROI and drag
it away. Luckily, this is easily fixed by using the undo feature.

Isolating the Scapula in Osirix
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Changing Pixel ValuesChanging Pixel Values
To isolate the scapula, all other pixels must be set to black. This was done earlier to ignore the humerus.
Use ROI->Set Pixel Values to...
In the details window, be sure to select ROIs with the same name, set pixels that are outside, and to the
new value: -3024.

Set the pixels inside ROIs to 500 to have a completely solid scapula. Once this is done, the scapula can
be viewed in the 3D surface rendering.

Isolating the Scapula in Osirix
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Surface RenderingSurface Rendering
To create the 3D surface, go to the tool bar, select 3D Viewer->3D Surface Rendering. Be sure that the
pixel value is set to 500.

Isolating the Scapula in Osirix
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Exporting the SurfaceExporting the Surface
Use the toolbar to export the surface as a wavefront (.obj) file.

Isolating the Scapula in Osirix
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Selecting Points of InterestSelecting Points of Interest
Use the bullseye tool to select the points of interest. The points of interest used to create the reference
frame are the center of the glenoid face, the point at which the scapula spine meets the medial border,
and the inferior-most point on the scapula. The center of the glenoid face is found using four points on
the rim of the glenoid.

Isolating the Scapula in Osirix
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Glenoid Face PointsGlenoid Face Points
The points used to determine the center of the glenoid are the inferior, superior, anterior, and posterior-
most points on the rim of the glenoid. The order in which the points are selected do not matter.

Isolating the Scapula in Osirix
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Medial and Inferior PointsMedial and Inferior Points
The inferior most point on the scapula is the lowest point. The point at which the scapula spine meets
the medial border is a little hard to determine. Try to place it in the middle of the spine, on the medial
edge.

Isolating the Scapula in Osirix
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Exporting the PointsExporting the Points
In order to export the points, you have to go to the 2D view window, and click Plug-ins-> ROI-> Export
ROI. Export the ROI as a .csv. The points will be listed under the ROIname (column H) “unnamed” in
the order they appear from inferior to superior.

Isolating the Scapula in Osirix
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C.2 Cleaning the Mesh in MeshLab and Netfabb

Netfabb: LoadNetfabb: Load
Netfabb has a simple repair function useful for closing holes, and correcting face normals. While
Meshlab has some great smoothing and remeshing features, it does not do a great job at closing holes.
To load a mesh click the open button circled in red. In this picture, the exclamation mark indicates their
are some errors in the mesh that need to be repaired.
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Netfabb: RepairNetfabb: Repair
To begin the repair process, click the red cross on the top bar (circled in red.) The status bar shows the
amount of edges, triangles, shells, and holes in the entire mesh. To start the repair, click on "Repair
scripts" in the bottom right hand corner, and then "Execute." After executing the repair, select "Apply
repair."
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Netfabb: SaveNetfabb: Save
To export the mesh, select Part->Export part->as STL.
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Meshlab: Load MeshMeshlab: Load Mesh
MeshLab is used to further clean the scapula, and isolate the glenoid. It is an open source software, and
there are many tutorials available online. In order to open the file, select File->Import Mesh.

When working in Meshlab, there is no undo option after taking an action. However, in the case of an
error, the mesh can always be reloaded using File->Reload.

In this view it is possible to see the properties of the mesh. The bar on the bottom of the window
displays the mesh file name, and the number of faces and vertices. When faces or vertices are selected,
the number of selected items is also displayed.
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Meshlab: Select Extra MeshesMeshlab: Select Extra Meshes
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Meshlab: Removing excess geometriesMeshlab: Removing excess geometries
If, when using Osirix, the brush tool was not used to fill in all the holes in the region of interest, there
may be some internal geometries present. These unconnected faces can be easily deleted. First, use the
Connected Components selector to select the whole scapula. This button is circled in green. Then, use
Filters->Selection->Invert Selection. Since the Connected Compoents selector only selects the faces, it is
important to uncelect the "Invert Vertices" option. Use the Faces and Vertices delete button (circled in
red) to get rid of these internal geometries.
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Meshlab: FiltersMeshlab: Filters
When the mesh is first opened, it needs to be cleaned of any errors. This involves the following
commands in the order listed: Filters->Cleaning and Repairing->Select Self Intersecting Faces, and
Select Non Manifold Vertices. If any edges or vertices are selected, (visible in the purple bar at the
bottom of the screen) delete them using the circled delete selected faces and vertices button.
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Meshlab: Close HolesMeshlab: Close Holes
Although most of the hole processing is done in Netfabb, most of the holes can be closed using Filters-
>Remeshing...->Close Holes.
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Meshlab: SmoothingMeshlab: Smoothing
The mesh is pretty pixelated at the start, so smooth the mesh to get the correct shape. To do this, click
Filters->Smoothing...->Laplacian Smooth.
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Meshlab: ExportMeshlab: Export
The scapula need to be saved as a stereolythography (.stl) file. Use File->Export Mesh As, and select
STL File Format from the naming window. Be sure to name the scapula appropriately based on what is
being saved: patient#_scapula, patient#_fullscapmini, patient#_rim. If faces were deleted, it is useful to
go back to Netfabb to fix any holes by repeating the repair process.
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MeshLab: SimplifyMeshLab: Simplify
To identify landmarks on the scapula in matlab, the filesize of the scapula must be reduced. This is
done using the Quadric Edge Collapse, found in Filters->Remeshing. Set the target number of faces to
10,000.
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Meshlab: Simplified MeshMeshlab: Simplified Mesh
A view of the front of the scapula once it is remeshed.
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Meshlab: Isolating the GlenoidMeshlab: Isolating the Glenoid
In order to isolate the glenoid and rim the selection tool is used. Select using the "Select Faces in a
rectangular region" tool. This tool automatically selects all the faces in the rectangular region created,
even those that are blocked from view by other faces. In order to only select the visible faces, hold down
option. To add to the selected faces, hold down command while clicking, to subtract faces, hold down
shift. Invert selection as necessary, and delete the selection by using "Delete Selected Faces and
Veritces."
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MeshLab: Glenoid and RimMeshLab: Glenoid and Rim
The finale glenoid and rim doesn't have to be perfect, since the concave section of the face will be
isolated in Matlab.
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